Started about 1 year agoJune 25, 2025Lasted about 2 hoursJune 25, 20252:234:24 PMUTC
Affected
Supplier Performance
Major outage from 2:23 PM to 4:24 PM
PaxFaB
Major outage from 2:23 PM to 4:24 PM
Updates
Resolved
UTC
Resolved
UTC
After monitoring supplier performance, we have concluded that the issue has been resolved.
Identified
UTC
Identified
UTC
We have temporarily disabled the supplier to investigate performance issues.
Our technical team are currently working to resolve this issue.
Further updates will be provided as soon as possible.